[code][/code]

Pump Noise

Discuss watercooling here.
zoomee
Lance Corporal
Lance Corporal
Posts: 113
Joined: Wed May 21, 2014 7:27 pm

Pump Noise

Post #1 by zoomee » Tue Jul 22, 2014 11:26 pm

Postby EK_Derick » Thu Jul 17, 2014 8:58 am
I don't mean take it apart completely. Just separate the top from the pump, shouldn't void your warranty. Inspect the parts and give a good rinse. Put it back together normally and see if the noise continues.

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

Just a quick update bud, I was lazy and went back to the supplier - Scan are awesome! - no questions asked they just swapped it out for a new one even though it was three months old!

Got it sat here staring at me - will give it a shot and post back tomorrow hopefully.


4960x@4.7 / 16Gb@2400 / R9 290 / Custom W/C

zoomee
Lance Corporal
Lance Corporal
Posts: 113
Joined: Wed May 21, 2014 7:27 pm

Re: Pump Noise

Post #2 by zoomee » Wed Jul 23, 2014 6:37 pm

wow! - pleased to say there is no longer any noise when running this pump at full whack!
Looks like I had a dodgy 'un :)

Thanks EK Derrick for recommending to RMA it - otherwise I never would have lol - took me 3 months to get round to doing it :)
4960x@4.7 / 16Gb@2400 / R9 290 / Custom W/C

User avatar
EK_Derick
Cadet
Cadet
Posts: 18
Joined: Sun Jul 06, 2014 7:31 am
Location: Ljubljana, Slovenia
Contact:

Re: Pump Noise

Post #3 by EK_Derick » Fri Aug 01, 2014 4:11 am

Glad to hear it :)
Intel Xeon X5680 - EK-Supremacy Nickel Acetal
Asus Rampage III Black Edition - EK-R3BE Full Board
Corsair Dominator GT 3 x 4GB - EK-Monarch X6
(4) Asus Matrix 7970 Platinum - EK-FC 7970 Matrix
LEPA G1600W + Enermax Platimax 600W
Silverstone TJ07


Return to “Watercooling”




  Who is online

Users browsing this forum: No registered users and 1 guest

cron